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1. Introduction 

Overview 
With most remote data acquisition systems, during daily operations, we need additional human resources to 
collect data manually from remote storage devices for loading into a database. Even with remote I/O 
devices remotely collecting data over a network, software must be developed to handle converting and 
uploading data logs. Moxa’s MX-AOPC UA Logger not only makes real-time data collection much easier, it 
also simplifies the conversion of historical data into database-ready formats. Moxa’s MX-AOPC UA Logger 
interacts directly with our MX-AOPC UA Server, working as a bridge between field data and cloud storage, as 
well as stored databases or spreadsheets. The MX-AOPC UA Logger can collate tags from individual Moxa 
remote I/O devices into the same cloud, database, or spreadsheet, freeing users from the need to 
manipulate data after processing. 

One benefit of using remote I/O devices is that you can collect data over a network from a central site. In 
an ideal operation, after a network failure, remote I/O devices should be able to transmit data logs that 
were collected while the network was offline. Moxa’s MX-AOPC UA Logger makes this not only possible, but 
easy. MX-AOPC UA Loggers provide a standard OPC interface that interacts with MX-AOPC UA Servers for 
real-time data collection. After each network connection, an MX-AOPC UA Logger will compare historical 
data stored on the microSD cards in individual ioLogik 2500 devices with the real-time data it has already 
stored locally, and then supplement any missing data by requesting that the ioLogik 2500 retransmit the 
lost data. Furthermore, MX-AOPC UA Logger also supports functions for providing data on schedule and on 
demand. It will automatically retrieve the lost data when the on-schedule or on-demand function is 
triggered. 

The MX-AOPC UA Logger includes: 

• Logger Runtime Service: Starts as a service by default after installation. 

• Configuration Console: A configuration tool for configuring settings. 

System Requirements 
Hardware Requirements 
CPU: Intel Pentium 4 or above 
RAM: 512 MB (1024 MB or higher is recommended) 
Communication Interface: Ethernet 
 Software Requirements 
Operating System: Microsoft Windows 7/8/10/11, Microsoft Windows Server 
2003/2008/2012/2016/2019/2022 
Microsoft .NET Framework: v3.5 Service Pack 1 
Editor (optional): Microsoft Office 2003 (Access or Excel) or later 
Database (optional): Oracle database (x86), Microsoft SQL Server (x86), MySQL (x86) 
Cloud (optional): Microsoft Azure 
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Specifications 
OPC Specifications 
OPC Unified Architecture: 1.02 
 Products that Support Data Supplement Auto Mode, on Schedule, and on Demand 
Model Names: ioLogik 2500 series 
Note: Please check Moxa’s website for the most up-to-date list of supported products. 
 Fully Supported OPC UA Client Profiles 
• Core Client Facet 
• User Token: User Name Password Client Facet 
• User Token: X509 Certificate Client Facet 
• Security Policy: Basic128Rsa15, Basic256Sha256 
• Security Policy: None 
• Data Access Client Facet 
• UA-TCP UA-SC UA Binary 
• Attribute Write Client Facet 
• Data Change Subscriber Client Facet 
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2. Getting Started 

Designing the System Architecture 
The MX-AOPC UA Logger provides two major functions. 

• Storing real-time data collected through an MX-AOPC UA Server from individual I/O devices to a 
database or spreadsheet. 

• Retrieving buffered data stored on a microSD card in a Moxa device that supports data buffering, such 
as the Moxa ioLogik 2500 series, and then supplementing the database or spreadsheet with missing 
data. 

We recommend using one of the following two scenarios when designing the system architecture: 

Scenario 1: Write real-time data to a database, spreadsheet, or Azure Cloud 
• MX-AOPC UA Logger saves data from selected OPC tags to a database, spreadsheet, or Azure Cloud. 

The data comes from MX-AOPC UA Server only, which collects data from field devices. 

• MX-AOPC UA Server, MX-AOPC UA Logger, and Database can be installed either on the same computer 
or on different computers. We strongly recommend installing MX-AOPC UA Logger and Database on the 
same computer. 
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Scenario 2: Collect real-time data while the network is up and running, and 
retrieve buffered data stored in Moxa devices when the network is 
disconnected 
• Refer to Scenario 1 for real-time data collection. 

• When network communication is reestablished, the MX-AOPC UA Logger automatically retrieves 
buffered data saved on microSD cards installed in Moxa’s devices when the network was disconnected. 

• After retrieving data from the data logs, the MX-AOPC UA Logger automatically saves the data to the 
database or spreadsheet. 

• The MX-AOPC UA Logger supplements data only for OPC tags, which are selected both in the AOPC 
function of the Moxa device with the IOxpress utility (AOPC > Tag Selection), and in the Logger 
settings of the MX-AOPC UA Logger with its configuration console. 

• For this scenario, you must install microSD cards in your Moxa devices. 

• The MX-AOPC UA Logger's data supplement function must be enabled (the default), which can be done 
with the configuration console under Tools > Data Supplement Settings. 

• If the IP address of the Moxa cellular device is private or dynamic, Cellular Data Access software must 
enable the MX-AOPC UA Logger to access Moxa cellular devices. We recommend installing the Cellular 
Data Access software and MX-AOPC UA Server on the same computer. Use Moxa's IOxpress utility to 
enable the Cellular Data Access function on the Moxa cellular device at Network > Cellular > Cellular 
Data Access. Use the MX-AOPC UA Logger's configuration console at Tools > Data Supplement 
Settings. 

When the Moxa cellular device uses a static IP 
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When the Moxa cellular device uses a private or dynamic IP 

 

You can download the following software from Moxa’s website at www.moxa.com: 

• MX-AOPC UA Logger v2.0 or later 

• MX-AOPC UA Server v2.0 or later 

• Cellular Data Access v1.2 or later 

• IOxpress utility v2.1 or later 

• Moxa device firmware that supports the data supplement function: 

 ioLogik 2500 series 

 ioLogik 2500-Ethernet v2.2 or later 

 ioLogik 2500-HSPA v2.2 or later 

 ioLogik 2500-WL1 v2.2 or later 

Refer to the MX-AOPC UA Server User’s Manual for instructions on how to install and configure Moxa’s MX-
AOPC UA Server software. 

Refer to your Moxa device’s user’s manual for instructions on installing IOxpress and Cellular Data Access on 
a computer, and for updating your Moxa device’s firmware. 

Installing the MX-AOPC UA Logger 
The MX-AOPC UA Logger can be downloaded from Moxa’s website at www.moxa.com. 

After downloading the file, unzip it and run setup.exe. The installation program will guide you through the 
MX-AOPC UA Logger installation process. 
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Opening the Configuration Console 
Open the MX-AOPC UA Logger's configuration console from the Windows Start menu: Start > All 
Programs > MOXA > IO Server > MX-AOPC UA Suite > MX-AOPC UA Logger. 

Select the appropriate main network adapter the first time you open the configuration console. 

 

The configuration console is a configuration tool for configuring Logger Runtime settings. When the 
configuration console is launched, it will automatically get the latest configurations from the Logger 
Runtime. 
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Configuring the MX-AOPC UA Logger Settings 
The MX-AOPC UA Logger settings described below can be configured under the Tools menu. 

 

• Change Password 

We strongly recommend changing the password the first time you use the Configuration Console. The 
default password is moxa, which is needed for verification when exporting the system log to a text file. 

• Data Supplement Settings 

Select the Data supplement after network reconnection checkbox if the Moxa product supporting 
the data supplement function is connected to an MX-AOPC UA Server. 

Select the Data supplement on the schedule checkbox if the Moxa product supporting the data 
supplement on schedule function is connected to an MX-AOPC UA Server. 

Select the Data Supplement through the Cellular Data Access checkbox if the IP address of the 
Moxa cellular device is private or dynamic. 
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• Certificate Management 

If the security policy of the MX-AOPC UA Server is set aside from None, importing an OPC UA client’s 
CA (Certificate Authority) file into the MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA 
file to OPC UA Clients are both required. 

Click the Trust Servers tab, click Import, and select the server’s CA file to import it into the MX-AOPC 
UA Logger. 

 
Select the Instance Certificates tab and click on Export Logger Certificate to export the MX-AOPC 
UA Logger’s CA file to the OPC UA Server. 
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 NOTE 
 After reissuing certificates or re-installing the MX-AOPC UA Logger, you will need to export the Logger 

Certificate to the OPC UA Server again. 
 

Connecting to the MX-AOPC UA Server 

Getting the Server Endpoint from the MX-AOPC UA Server 

Open the MX-AOPC UA Server configuration console and select Tools > OPC UA Settings > Server 
Endpoint Settings to go to the MX-AOPC UA Server configuration console to copy the MX-AOPC UA 
Server's Server Endpoint. 

Ensure that the status of the Server Endpoint is Valid. 
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Connecting to MX-AOPC UA Servers 

1. Click the Server Group and then click the Discovery icon to discover MX-AOPC UA Servers. 

 

2. Select the Local Server option if MX-AOPC UA Server and MX-AOPC UA Logger are installed on the 
same computer. Otherwise, select the Remote Server Endpoint option and paste in the Server 
Endpoint from the previous step. Type in the MX-AOPC UA Server’s password and then click Next. 
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3. Change Server Name, and configure Security Policy and Security Mode, which should be the same 
as the MX-AOPC UA Server’s UA Settings. If necessary, change the Publish Interval, Sampling 
Interval, Queue Size settings, and select or deselect the Discard Oldest settings checkbox, and then 
click Finish. 

 

4. Select the server and click the Connect icon to connect to the MX-AOPC UA Server. 
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5. Once the server is connected, you will not be allowed to change the server connection settings. To 
change the server connection settings, click the Disconnect icon to disconnect the MX-AOPC UA 
Server, and then click the Properties icon to change the server connection settings. 

 

 

 NOTE 
 Ensure that the server connection is in connecting status before recording data to a database or 

spreadsheet. 
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Creating Loggers 
1. To create a data Logger, click Logger Group List, click the New Logger Group icon, and then type in 

the name of the logger group. 

 

2. Click the logger group, and then click the New Logger icon to create a logger. 

3. Type in the logger's name, select Excel File, Access File, Database, or Azure IoT, and then change 
the root path. Set the source name of the database, or type in the Connection String. Click Next to 
continue. 
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4. If necessary, change the name and order of Table Fields. Add <DATA_TYPE>, 
<SERVER_UTC_TIMESTAMP>, etc., if they are required to be recorded into the database or 
spreadsheet, and then click Finish. 

 
5. Click the Refresh button to get the latest MX-AOPC UA Server OPC tags. 
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6. Click the appropriate arrow buttons to add items to or remove items from the Selected Tags list. 

 

Starting Runtime Service 
After connecting the MX-AOPC UA Server and creating the Logger, click the Start Runtime Service icon to 
run the MX-AOPC UA Logger service. 
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A green light next to the logger name shows the logger is ready to record. 

 

A yellow light next to the logger name shows that the logger setting is not correct. Check the settings of the 
logger, and then confirm the database or spreadsheet settings again. 
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You will not be allowed to change the server connection and logger settings when runtime service is 
running. To stop runtime service, click the Stop Runtime Service icon. 

 

 NOTE 
 Configuration changes will be updated to Logger’s runtime service after the runtime service is started. If 

the runtime service is not started, any changes will be discarded when the configuration console is closed. 
Be sure to save your project file when you close the configuration console. 

 

 NOTE 
 Stopping Runtime Service will stop both the logger recording and data supplement functions, which may 

cause data loss. 
 

Starting Recording 
To record data, click the logger icon and then click the Start Recording icon to record the selected tags 
into the database or spreadsheet. 
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A red light next to the logger indicates that the logger is recording. 

 

Click the folder icon to check if data is being recorded in the target spreadsheet. 

 

 NOTE 
 Be sure to close the target spreadsheet listed in the target root path before recording. If the target 

spreadsheet is open, the MX-AOPC UA Logger cannot record data to the target file. 
 

 NOTE 
 DO NOT open the spreadsheet while recording is under way. Doing so will cause the spreadsheet file to 

become corrupted because it is in use by the MX-AOPC UA Logger service. To open the spreadsheet, stop 
the MX-AOPC UA Logger’s runtime service and then click the folder icon to access the file. 
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Testing the Data Supplement Function 
Take the following steps to test the data supplement function. 

1. Insert a microSD card into your Moxa device. 

2. Use IOxpress to configure the Moxa device to allocate data buffer size for network failure and to enable 
connection to the MX-AOPC UA Server. 

 

 

3. Select the checkboxes of the tags associated with the data you would like the MX-AOPC UA Server to 
update. 
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4. If the cellular device’s SIM card uses a private or dynamic IP address, enable the Cellular Data Access 
function. If the SIM card is using a public IP address, continue with step 5. 

 
5. Update the device’s configuration. 

 

6. Conduct Set Device Date & Time on the device to ensure that the device, MX-AOPC UA Server, and 
MX-AOPC UA Logger are time synchronized. 
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7. If Cellular Data Access software is required, enable the MX-AOPC UA Logger's Data supplement 
through Cellular Data Access option at Tools > Data Supplement Settings. If Cellular Data Access 
software is not required, continue with step 8. 

 
8. Ensure that the logger is in recording mode. 
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9. Disconnect the Ethernet connection between the Moxa device and the MX-AOPC UA Server. Wait longer 
than the heartbeat interval (the ioLogik 2500’s default heartbeat interval is 30 sec.) plus the heartbeat 
tolerance (the MX-AOPC UA Server’s default heartbeat tolerance is 30 sec.), and then check if the tag 
status is “Disconnected” on the MX-AOPC UA Viewer. If it is disconnected, wait longer than the update 
interval of the tags, and then reconnect the connection between the Moxa device and MX-AOPC UA 
Server. 

 

10. The pink and gray flashing light indicates that the logger is performing the data supplement process. 
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11. After the data supplement process is complete, the light will change to red. The event log will show how 
long the data supplement process took to perform, and the result of the supplement process. 

 

12. Open the database folder and note which files the supplementary data has been saved to. 
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Testing the Data Supplement on Demand 
Function 

Take the following steps to test the data on the demand function. 

1. Ensure the logger is in recording mode. 

 

2. Click the Stop Recording button to stop recording data, and then wait. 
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3. Click Logger Group List and then click the Data Supplement on Demand button. The default on-
demand period is one day in the past. 

 
4. Click the Retrieve button to retrieve lost data in the defined period. The pink and gray flashing light 

shows that the logger is performing the data supplement process. 
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5. Once the retrieving process is finished, the Result column will show Complete. 

 
6. To check detailed information, see the Log View at the bottom of the screen. 
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Testing the Data Supplement on Schedule 
Function 

Take the following steps to test the data on the demand function. 

1. Ensure that the runtime service is NOT in run mode. 

 
2. Click Tools > Data Supplement Settings. 
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3. Enable the Data supplement on schedule function, set the time (UTC Time) to a few minutes later 
and data loss in the past to 1 day. 

 
4. Start the run time service. 
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5. Start recording the logger. 

 

6. When the specified time elapses, the data supplement on schedule function will be triggered. It will 
display the progress in the Log View as shown below. 
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3. Configuration Console 

Main Screen Overview 
The MX-AOPC UA Logger’s configuration console displays settings for connected MX-AOPC UA Servers and 
loggers. It also shows the logger runtime status. 

 

No. Zone Description 
1 Software Title Displays the name of the software: MX-AOPC UA Logger 
2 Menu Bar All configuration functions can be accessed from these menu items 
3 Quick Launch Bar Frequently used icons 
4 Server View All MX-AOPC UA Servers 
5 Logger View All Loggers 
6 Detailed View Detailed settings of the servers and loggers 
7 Log View Logger Runtime logs 
8 Runtime Service Status Shows if the logger runtime service is Running or Stopped 
9 Logger Time Displays the Logger time (same as the PC’s time) 
10 Data Supplement Queue Displays the data supplement waiting items in the queue 
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Menu Items 

File 

Use the File menu to manage project files. 

 

• New: Create a new project file. 

• Open: Open an existing project file. 

• Save: Save the current project. 

• Save As: Save the current project file as another project with a different filename. 

• Previous saved files: Quickly open previously saved project files. 

• Exit: Close the Configuration Console. 
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Server 

Use the Server menu to edit MX-AOPC UA Server connection settings. 

 

 

• Discovery: Discover MX-AOPC UA Servers and configure its connection settings. 

• Connect: Connect the selected server. 

• Disconnect: Disconnect the selected server. 

• Delete: Delete the selected server. 

• Properties: change the settings of the selected server. 

 NOTE 
 The properties of a server cannot be changed either when the server is in connecting mode, or runtime 

service is in running mode. Stop runtime service and disconnect the server connection before modifying 
the server properties. 
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Logger 

Use the Logger menu to edit logger settings. 

 

• New Logger Group: Create a new logger group. 

• New Logger: Create a new logger. 

• Delete: Delete the selected logger. 

• Start Recording: Start recording for a selected logger group or a selected logger. 

• Stop Recording: Stop recording for a selected logger group or a selected logger. 

• Data Supplement on Demand: Retrieve lost data during a specified period. Refer to Testing Data 
Supplement on Demand in Chapter 2. 

• Terminate Data Supplement: Terminates all the data supplement waiting items in the queue. 

• Properties: change the settings of an existing logger. 

 NOTE 
 The properties of a logger cannot be changed either when the logger is in recording mode, or runtime 

service is in running mode. Stop runtime service before modifying logger properties. 
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Tools 

Use the Tools menu to configure data supplement settings for certificate management, to access a system 
log, to change a password, or to change console environment settings. 

 

• Data Supplement Settings 

 
 General Settings: 
 Retry Timeout: The retry timeout interval for retrieving supplementary data from a device’s 

buffer.  
 Retries: The number of retries allowed after a retry timeout. 
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 Triggering Event: Enable the following functions if the Moxa products connected to an MX-AOPC 
UA Server supports the data supplement function. 
 Data supplement after network reconnection: Enable data supplement function after 

network reconnection. 
 Data supplement on schedule: Enable data supplement function on schedule at the specified 

time. You can set the triggering time to every day at a specific time. The data loss period can 
be set to 1 to 7 days in the past. 

 Data supplement through Cellular Data Access: Enable this function if the Moxa products 
connected to the Cellular Data Access software support the data supplement function. 
 IP Address: The IP address of the Cellular Data Access software. 
 Port: The listen port of the Cellular Data Access software. 

 Folder for supplementary data 

 Path: The folder path to which the system can temporarily save supplementary data. Click 

 to change the folder path. Click  to open the folder. Delete the supplementary 
data files after the data is written to the database.  

 Log Folder for Data Supplementary on Demand 

 Path: The folder path to which the system can temporarily save the log files of the 

supplementary data on demand. Click  to change the folder path. 

• Certificate Management 

If the security policy of the MX-AOPC UA Server is set to aside from None, importing an OPC UA client’s 
CA (Certificate Authority) file into the MX-AOPC UA Server, and exporting the MX-AOPC UA Server’s CA 
file to OPC UA Clients are both required. 

Click the Trust Servers tab, click Import, and select the server’s CA file to import it into the MX-AOPC 
UA Logger. Click Export to export the selected certificate. Click Remove to remove the selected 
certificate. Click Trust to trust the selected certificate. Click View Certificate to view the selected 
certificate. 
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Click the Instance Certificates tab and click Export Logger Certificate to export the MX-AOPC UA 
Logger’s CA file to OPC UA Server. 

 

 NOTE 
 After reissuing certificates or re-installing the MX-AOPC UA Logger, you will need to export the Logger 

Certificate to the OPC UA Server again. 
 

• System Log 

 

 Save to Text File: Save the MX-AOPC UA Logger’s system log to a text file. You will be required to 
enter a password (default password = moxa). 
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 Reset System Log: Reset the MX-AOPC UA Logger’s system log. You will be required to enter a 
password (default password = moxa). 

      
 System Log Settings: Defines the maximum number of records that can be saved in the MX-AOPC 

UA Logger’s system log (values can range from 1 to 30000; the default value is 30000). 

 

• Change Password: Change the MX-AOPC UA Logger’s system password. The password is required 
when updating configurations to System Runtime, saving system logs to a text file, or resetting the 
system log (length: 4 to 128; acceptable characters: A to Z, a to z, 0 to 9, Symbols; default: moxa). 

 

• Options: Configure environment settings for the MX-AOPC UA Logger’s configuration console. 

 

 NOTE 
 If Automatically save configuration every xx min(s) is enabled, the configuration file will be 

automatically saved only when a filename is defined. Be sure to save your configuration file after creating 
a new project file. 
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Runtime 

Use the Runtime menu to Start, Stop, or Reinitialize Server Runtime Service. 

 

Help 

Use the Help menu to launch the Logger’s help documentation, to check the Logger’s license status, to add 
a license file, or to check the logger version. 

 

• Logger Help: Launch the MX-AOPC UA Logger’s help documentation. 

• Licensing 

 

 License Info: Displays the Logger’s User Code, License Status, and the Time Remaining on the 
license. Refer to License Registration and Activation to learn how to activate the license. 
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 Add License File: Import a license file after completing the license registration process. Refer to 
License Registration and Activation to learn how to activate the license. 

 Deactivate License: Deactivate the current paid license version and load factory default settings. 
Note that when you deactivate the license, your license file and runtime configurations will be 
deleted. Be sure to back up your runtime configurations before executing a license deactivation 
procedure. 

• About: Displays the MX-AOPC UA Logger’s version number and build number. 
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4. Server Management 

Server Discovery 
In this section we explain how to discover an MX-AOPC UA Server. 

An MX-AOPC UA Logger can discover MX-AOPC UA Servers installed on a local or remote computer. First, 
get the server endpoint, and then follow the onscreen instructions to discover the server. After the server 
has been discovered, be sure to connect to the server before adding the tags into loggers for recording. 

 NOTE 
 The server discovery or server connection settings can only be configured when the runtime service status 

is stopped. To stop the runtime, click the stop runtime icon on the quick launch bar. 

  
 

Getting the Server Endpoint from an MX-AOPC UA Server 

1. Open the MX-AOPC UA Server configuration console by clicking Tools > OPC UA Settings > Server 
Endpoint Settings. Be sure the status of the Server Endpoint is valid, and then copy the Server 
Endpoint of the MX-AOPC UA Server. 
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2. Go to Tools > OPC UA Settings > Security Policy Setting and confirm the MX-AOPC UA Server’s 
security policy settings. The security policy applies to connections between OPC UA clients and the MX-
AOPC UA Server. Besides, you will need to configure Certificates Management settings on both MX-
AOPC UA Server (Tools > OPC UA Settings > Certificates Management) and MX-AOPC UA Logger 
(Tools > Certificate Management). If only “None” is selected, you only need to know the password 
of the MX-AOPC UA Server. 

 

Discovering MX-AOPC UA Servers 

1. Go to the MX-AOPC UA Logger, right click a Server Group and then click Discovery in the pop-up 
menu, or click the Server Group to select it and then click the Discovery icon on the quick launch 
toolbar to discover MX-AOPC UA Servers. 

 

2. Select Local Server if the MX-AOPC UA Server and MX-AOPC UA Logger are installed on the same 
computer, or click Remote Server Endpoint and type in the target Server Endpoint. Next, type in the 
password of the MX-AOPC UA Server, and then click the Next button. 
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3. Change Server Name, and configure Security Policy and Security Mode to be the same as the MX-
AOPC UA Server’s UA Settings. If necessary, update the Publish Interval, Sampling Interval, Queue 
Size, or Discard Oldest settings, and then click Finish. 

 

 Server Name: Give a name for the connection of the MX-AOPC UA Server (max. length = 30; a 
period “.” is not allowed). The server name should be unique and cannot be changed after you click 
Finish. 

 Server Endpoint: The server endpoint of the discovered MX-AOPC UA Server. 
 Security Policy: Configure the same security policy as the MX-AOPC UA Server. 
 Security Mode: Configure the same security mode as the MX-AOPC UA Server. 
 Subscription Settings: Configure the subscription settings for MX-AOPC UA Logger to receive OPC 

tag data from the MX-AOPC UA Server. 
 Publish Interval: The publish interval defines the rate at which the Server sends OPC tag data 

to the Logger (unit: ms; values: 0 to 86400000; default: 1000; 0: the fastest practical rate). 
 Keep Alive Count: The keep alive count defines the number of publish intervals that must 

expire before a keep alive message is sent to MX-AOPC UA Server. 
 Lifetime Count: The lifetime count defines the number of times of publish interval can expire 

without the MX-AOPC UA Logger sending data updates or keep alive messages before the 
server deletes the subscription. 

• Monitored Item Settings 
 Sampling Interval: The sampling interval defines the rate at which the server checks for changes 

in the monitored device readings (unit: ms; values: -1 to 86400000; default: 500; the default 
interval set by the server: -1; the fastest practical rate: 0). 

 Queue Size: The queue size defines the number of data updates that the OPC UA Server will queue 
for the subscription 

 Discard Oldest: The discard oldest defines the discard policy of the queue. When checked, the 
oldest notification in the queue will be discarded and will not be sent to the MX-AOPC UA Logger. 
When unchecked, the latest notification will be discarded and will not be sent to the MX-AOPC UA 
Logger (default setting: enabled). 
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Server Connection 
In this section, we explain how to connect to the discovered MX-AOPC UA Server, and how to change the 
connection settings. 

Connecting to the discovered MX-AOPC UA Server 

Before configuring the logger, you must first connect to the discovered MX-AOPC UA Server to get the OPC 
tag list from the servers. 

1. Ensure the runtime service is stop. 

2. Right click the server and click Connect in the pop-up menu, or click the server to select it and then 
click the Connect icon on the quick launch toolbar. The server should now be connected to the MX-
AOPC UA Logger. 
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Editing the connection settings of the discovered MX-AOPC 
UA Server 

Take the following steps to edit the connection settings of the discovered MX-AOPC UA Server: 

1. Ensure the runtime service is stopped. 

2. Right click the server and click Disconnect in the pop-up menu, or click the server to select it and then 
click the Disconnect icon on the quick launch toolbar. 

 

3. Right click the server and click Properties in the pop-up menu, or click the server to select it and then 
click the Properties icon on the quick launch toolbar. Follow the onscreen instructions to edit the 
settings. 

 

 NOTE 
 The server name cannot be changed after the initial setting. To change the server name, delete the 

original server settings and then use the server discovery process to create a new one. Note that deleting 
the server connection settings will delete all the related logger settings at the same time. 
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Deleting the connection settings of the discovered MX-AOPC 
UA Server 

Take the following steps to delete the connection settings of the discovered MX-AOPC UA Server: 

1. Ensure the runtime service is stopped. 

2. Right click the server and click Delete in the pop-up menu, or click the server to select it and then click 
the Delete icon on the quick launch toolbar. 

 

3. Click OK to confirm that you would like to delete logger settings at the same time. 
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5. Logger Management 

Logger Group 
In this section, we explain how to use the configuration console to add, edit, and delete logger groups. 

Adding a Logger Group to a Logger Group List 

1. Ensure that the runtime service is stopped. 

2. Right click the Logger Group List and then click New Logger Group in the pop-up menu, or click the 
Logger Group List to select it and then click the New Tag Group icon on the Quick Launch toolbar. 

 

3. Type in the name of the logger group (max. length = 30 characters; “.” is not allowed) and then click 
OK. 
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4. The new logger group will be added to the Logger Group List. 

 

Editing a Logger Group 

Right click the logger group and then click Properties in the pop-up menu, or click the logger group to 
select it and then click the Properties icon on the Quick Launch toolbar. 

 

Deleting a Logger Group 

Right click the logger group and then click Delete in the pop-up menu, or click the logger group to select it 
and then click the Delete icon on the Quick Launch toolbar. 
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Loggers 
In this section, we explain how to use the configuration console to add, edit, and delete loggers. 

Adding a Logger to a Tag Group 

1. Ensure the runtime service is stopped. 

2. Right click on the logger group that the logger will be added to and then click New Logger in the pop-
up menu, or click the logger group to select it and then click the New Logger icon on the Quick Launch 
toolbar. 
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3. Type in the logger's name, configure the data file type, database or Azure IoT, and then click Next. 

 

 Logger Name: The naming rules of the logger name depend on the specifications of Microsoft 
Excel, Access, SQL Server, Oracle Database, or Azure IoT. We can summarize the naming rules as 
follows: 
 Microsoft Excel (max. length = 30; the first four characters: a-z, A-z; the following characters: 

0-9, a-z, A-Z, _) 
 Microsoft Access (max. length = 30; the following characters are NOT allowed: . ! ` [ ] ' ,) 
 Database Source Name (DSN) and Azure IoT (max. length = 30 (only 20 if using Oracle 

Database); the following characters are NOT allowed: . [ ] ' ,”) 
 Excel File: Select this option if you would like to record data into Excel files. Configure the root path 

for saving those files. Configure the time if you would like to separate the files by interval. 
 Access File: Select this option if you would like to record data into Access files. Configure the root 

path for saving those files. 
 Database: Select this option if you would like to record data into a Microsoft SQL Server or Oracle 

database. Refer to Appendix B for details on how to configure the database connection settings. 
 Azure IoT: Select this option if you would like to record data in a Microsoft Azure IoT Cloud. Copy 

the Connection String you got from Microsoft Azure and paste it into this field. 
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4. Select the Data Field items, change the default names in the Table Field, change the order of the items, 
and if necessary change the time format for the timestamp. Click Finish to save the settings. 

 

 Data Field: By default, data of <TAG_ID>, <VALUE>, <UNIT>, <SOURCE_UTC_TIMESTAMP>, 
<SOURCE_TIMEZONE> will be recorded into the database. Data of <DATA_TYPE>, 
<SERVER_UTC_TIMESTAMP>, <SERVER_TIMEZONE>, and <QUALITY> are optional. The time data 
of <SOURCE_UTC_TIMESTAMP> and <SOURCE_TIMEZONE> in an OPC tag is added by Moxa’s I/O 
device when the event occurs. The time data of <SERVER_UTC_TIMESTAMP> and 
<SERVER_TIMEZONE> in an OPC tag is added by the MX-AOPC UA Server when the tag is received. 

 Table Field: The name of each data field, which can be defined by the user, will be the column 
name of the table in the database. The max. length is 30 characters.  
The following characters are not allowed: ! # $ [ ] { } " ' ? . , `. 

 Data Type: The data type of the timestamp can be either DateTime or String type. If the second 
value of the timestamp has decimal points, select String type to record the decimal point value into 
the database. The DateTime format only supports integer values. 

: Move the selected item up. 

: Move the selected item down. 

 Automatically start recording when service runs: Enable this function if you want the logger to 
record automatically whenever the runtime service starts running. 
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Editing a Logger 

Take the following steps to edit a logger’s properties: 

1. Ensure the runtime service is stopped. 

2. Right click the logger and then click Properties in the pop-up menu, or click the logger to select it and 
then click the Properties icon on the Quick Launch toolbar. 
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Deleting a Logger 

Take the following steps to delete a logger: 

1. Ensure the runtime service is stopped. 

2. Right click the logger and click Delete in the pop-up menu, or click the logger to select it and then click 
the Delete icon on the quick launch toolbar. 

 

3. Click OK to confirm that you would like to delete this logger. 

 

 

  



 

 

MX-AOPC UA Logger User Manual 56 

Logger Recording 
In this section, we explain how to use the configuration console to select tags for recording, to start or stop 
recording, and to check the status of a logger. 

Select Tags for Recording 

1. Ensure the runtime service is stopped. 

2. Ensure that the server is connected. 

3. Click the refresh button to get the updated tags from the server. 
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4. Select the tag in the Available Tags list and click the arrow button to add it into the Selected Tags list.  

 

 : add all tags into the Selected Tags list. 

 : add a selected tag into the Selected Tags list. 

 : remove a selected tag from the Selected Tags list. 

 : removed all tags from the Selected Tags list. 

5. The data from the tags in the list shown below will be recorded after the logger is in recording mode. 
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Start or Stop Recording 

1. Ensure the runtime service is running. 

2. Ensure the server is connected. 

3. Ensure the logger is in ready mode (showed by green lights). 

4. To record all loggers in one logger group, right click on the logger group and then click Start 
Recording in the popup menu, or click the logger group to select it and then click the Start Recording 
icon on the Quick Launch toolbar. 

 

5. All of the loggers in the logger group will be in recording mode (showed by red lights). 
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6. To record a specific logger, right click on the logger and then click Start Recording in the pop-up 
menu, or click the logger to select it and then click the Start Recording icon on the Quick Launch 
toolbar. 

 

7. To stop recording, right click on the logger group or the logger and then click Stop Recording in the 
pop-up menu, or click the logger group or the logger to select it and then click the Stop Recording 
icon on the Quick Launch toolbar. 
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8. To check the recorded data, stop the runtime service and click the data folder of the logger. Open the 
data file in the folder to check the recorded data. 

 

 

 NOTE 
 Be sure to close the Excel or Access file at the target root path before recording. Otherwise, the MX-AOPC 

UA Logger cannot record data to the target file. 
 

 NOTE 
 DO NOT open the spreadsheet when recording. Doing so will cause the file to be corrupted because it is 

already opened by the MX-AOPC UA Logger service. To open the spreadsheet, stop the runtime service of 
the MX-AOPC UA Logger, and then click the folder icon to access the file. 
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Logger Status 

The following table gives the meanings of the logger status indicator lights. 

Light Color Status Note 

 
Solid Gray Configurable Mode 

The logger can be configured only when 
runtime service stops. 
Any configuration change will be updated to 
the Logger’s runtime service after starting the 
runtime service. Without starting the runtime 
service, any change will be discarded after the 
configuration console is closed. Be sure to save 
your project file when you close the 
configuration console. 

 
Solid Green Ready Mode The logger is ready for recording. 

 
Solid Red Recording Mode The logger is recording. 

 
Solid Yellow Error Mode – Configuration 

The logger is not configured correctly, and 
data is not being saved to the database. 
Check the tag selection or database connection 
of the logger. 

 

Flashing Red 
and Yellow 

Error Mode – Server 

A server related to some selected tags is 
disconnected. 
Check the server connection or server’s 
Endpoint settings. 

 

Flashing Pink 
and Gray 

Data Supplement Mode 
The logger is retrieving supplementary data 
from the device’s buffer storage, or 
supplementing data into the database. 
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6. License Registration and Activation 

Two versions of the MX-AOPC UA Logger are available. The trial version, which supports up to 1 MX-AOPC 
UA Server connection and up to 1 data logger, can be installed and used for 30 days without registration. To 
use the free version, you must submit a license registration. The free version only supports up to 1 MX-
AOPC UA Server connection and up to 1 data logger indefinitely. We summarize the two versions in the 
following table: 

Version MX-AOPC UA Server connection Data Logger Run Time License File 
Trial Up to 1 Up to 1 30 days Not Required 
Free Up to 1 Up to 1 Unlimited Required 

Take the following steps to register a license. 

Step 1: Get the PC User Code from the MX-AOPC UA Logger’s configuration console by clicking Help > 
License. 

 

Step 2: Go to Moxa's website (https://www.moxa.com) and log in with your Moxa account and password, 
or apply for an account if this is your first visit to the site. Navigate to Support > Software 
License Management to access the license portal. 
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Step 3: On the Software Licensing website, navigate to Products and Licenses > Activate a Product 
License. Select MX-AOPC UA Logger from Product Type, select Free Version from Sub Product 
Type, and enter the User Code. 

 

 

Step 4: Download the license file to a folder on your PC. 

 
Step 5: From the MX-AOPC UA Logger’s configuration console, click Help > Licensing > Add License 

File to add the license file (.lic) to the MX-AOPC UA Logger. 
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Step 6: After license activation is complete, go to Help > License Info to check the current license 
status. 
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A. System Performance Reference 

These performance results provide a reference for evaluating MX-AOPC UA Logger’s capability when 
designing a system architecture. The results show the maximum number of tags of data that can be 
recorded into the database without resulting in a data queue. 

• CPU: i7-4790, 3.60 GHz 

• RAM: 8 GB 

• Operating System: Microsoft Windows 7 

• Editor: Microsoft Office 2010 Access and Excel 

• Database: Oracle database, Microsoft SQL Server, MySQL 

• OPC UA Software: MX-AOPC UA Server & MX-AOPC UA Logger 

• Cloud: Azure IoT 

• Test Case: 

 One database at a time 
 Disabled data supplement function 
 Only running real-time data recording function 

Database Type Database 
Max. No. of Tags 
(per 1 second) 

Max. No. of Tags 
(per 5 seconds) 

File Excel 2000 10000 
File Access 3000 15000 
DSN Excel 2000 10000 
DSN Access 3000 15000 
DSN Microsoft SQL 1300 6500 
DSN Oracle 2000 10000 
DSN MySQL 800 4000 
Cloud Azure IoT 30 150 
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B. Database Connection Settings 

In this chapter, we explain how to connect a Logger to a Microsoft SQL Server or Oracle database. 

1. Open ODBC Data Source Administrator by typing “odbcad32.exe” in the Windows Start search field, 
and then click it. 

 
2. Click the System DNS tab and then click Add. 
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3. Select ODBC driver for Oracle if you are using an Oracle database, and select ODBC Driver xx for 
SQL Server if you are using a Microsoft SQL Server. In the example shown below, “ODBC Driver 11 for 
SQL Server” is selected. Click Finish to go to the next step. 

 

 NOTE 
 MX-AOPC UA Logger supports Oracle database (x86) and Microsoft SQL Server (x86) connections. 
 

4. Type a name for the data source in the Name field. Click the Server field down arrow to search for 
instances of SQL Server. Select your target SQL Server, and then click Finish. 
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5. Click Test Data Source to test the connection, or click OK to proceed. 

 

6. Click OK to complete ODBC Data Source settings. 
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7. Open Microsoft SQL Server Manage Studio. Right click on Security > Logins > NT 
AUTHORITY\SYSTEM, and then click Properties. 
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8. Ensure the default database is master. 
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9. Ensure that Public for Server Roles is enabled. 
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10. Enable the Master Database of the User Mapping, and enable the db_owner and public roles of the 
master. 

 
11. Select the Database option when setting the Logger’s data destination, and then click Setting. 
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12. Click the Machine Data Source tab, select the SQL Server data source, and then click OK. 

 

 NOTE 
 DO NOT click NEW from this window to configure ODBC Data Source settings. You will not be able to 

successfully connect the logger with the database. 
 

13. The data source name is displayed in the Source Name field. Click NEXT to continue the Logger 
Settings. Refer to Chapter 5 for information about the following settings. 

 

 


